[LCWO LOGO]  

Login

User name:
Password:


Language
Български Português brasileiro
Bosanski Català
繁體中文 Česky
Dansk Deutsch
English Español
Suomi Français
Ελληνικά Hrvatski
Magyar Italiano
日本語 Bahasa Melayu
Nederlands Norsk
Polski Português
Română Русский
සිංහල Slovenščina
Srpski Svenska
ภาษาไทย Türkçe
Українська 简体中文

Who is online? (18)


LCWO Discussion Forum [Atom LCWO Forum Feed]

This is a simple discussion forum for LCWO users. Feel free to use it for any kind of discussion related to this website.

Thread: MP3 "ILLEGAL FILE" error on older Olympus recorder/players...

Back to the Forum

AuthorText


Posted: 2012-11-20 08:50
I got "ILLEGAL FILE" errors playing downloaded MP3 practice files from LCWO.net on my Olympus WS-310M recorder/player.

An Olympus tech recreated the issue, and says that model can't handle LCWO.net's 11.025kHz MP3 sample rate. He had to transcode the files to 22 kHz in an audio editor (he suggested trying http://audacity.sourceforge.net/) to make it work.

How hard would it be to add a 22kHz encoding option to the CW settings? The tech said this issue only affects earlier Olympus players. Their newer players work OK: for example he named the WS-802.


Posted: 2012-11-20 11:10
I tried Audacity and it worked for me. I'm on Mac OS X, but it's cross-platform. Notes:

The setting to change is "Project Rate (Hz)" at the Audacity window's bottom. I set 22050.

Export the file as MP3. Make sure the filename ends with ".mp3" (the recorder needs it).

You can drag/drop several MP3 files into the audacity project window, change the project rate, then use Export Multiple to convert them all at once.

To use MP3 export, I was prompted to download and install the LAME library. Be very careful reading the download page, it's confusing.

For some reason my Mac's /user/local/lib folder was owned by "501" and had "700" (root only) permissions. To use (or even find) the LAME library, I had to open Terminal and "sudo cd /usr/local" and then "sudo chmod a+rx lib". (Leave the quotes out). Of course I had to type my admin password on the first sudo. I also did "sudo chown root lib", but I'm not sure I needed to.

(Su didn't work. I think it doesn't like some characters in my password. But then why does sudo...?)

After all that, Audacity found the LAME library OK and worked fine.


Posted: 2012-11-20 11:20
I meant to say "After installing, to use (or even find) the LAME library.."
[Moderator, if you could edit?...]
Administrator


Posted: 2012-12-06 07:49
Sorry for being so slow, lots of other stuff to do lately...

I know that some MP3 decoders struggle with various bit rates, but on the other side I wanted to keep the traffic which LCWO generates as low as possible, and changing the bit rate from 11kHz to 22kHz by default would roughly double it.

Making it an option that can be configured on the fly would be possible, and I will put it on my list of stuff to do, but at the moment my time is very limited, unfortunately...

73
Fabian

Back to the Forum

You must be logged in to post a message.

$Id: forum.php 62 2015-01-12 17:34:44Z fabian $