[LCWO LOGO]  

Login

User name:
Password:


Language
Български Português brasileiro
Bosanski Català
繁體中文 Česky
Dansk Deutsch
English Español
Suomi Français
Ελληνικά Hrvatski
Magyar Italiano
日本語 Bahasa Melayu
Nederlands Norsk
Polski Português
Română Русский
සිංහල Slovenščina
Srpski Svenska
ภาษาไทย Türkçe
Українська 简体中文

Who is online? (10)


LCWO Discussion Forum [Atom LCWO Forum Feed]

This is a simple discussion forum for LCWO users. Feel free to use it for any kind of discussion related to this website.

Thread: Browser compatibility.

Back to the Forum

AuthorText
Administrator


Posted: 2008-06-24 01:12
Hello,

the goal of LCWO is to work equally well with all common browsers and on all platforms.

LCWO is developed and tested with Firefox on Linux and Firefox & IE on Windows XP.

I'm very interested in reports from all users, especially those using different browsers and operating systems than I can test (OS X anyone?) about compatibility issues.

thanks & 73, Fabian


Posted: 2008-06-25 21:15
As requested by Fabian, an OS X test :

- LCWO works fine on ver. 10.4.11 with Safari 3.1.1 (4525.18)
- it works well with Firefox on OS X too

Thanks for this nice tool.
73, Phil F5IYJ


Posted: 2008-07-03 19:01
Works ok on Opera v9.51
73 Norby


Posted: 2008-07-04 15:53
Worked fine on Firefox 2.0.0.15

73/77 Feri


Posted: 2008-08-15 22:23
I get the example K and M to work but not the lesson 1 groups. This is using IE on Windows Vista. The idea is great so I hope this can be fixed.

Brian LA0DG
Administrator


Posted: 2008-08-15 22:29
Does a player show up at all in the lessons? Do you get sound, for example, on the plain text training?

I'll try to find the problem as soon as I have access to a Vista PC...

73, Fabian


Posted: 2008-08-16 14:55
With Firefox 2 on FreeBSD/amd64, with the linux flash plugin (32-bit), the inlined flash player crashes after just a few seconds. Since LCWO also has the option of playing plain mp3s, it makes LCWO useful on this platform :) I hope you will keep it this way, and not go "flash-only".

Thanks for a good, clean, and useful website.


Posted: 2008-08-17 06:33
Works with Firefox 3.0.1 on WinXP SP2 with Flash 9.0.124.0.

I also like the ability to create the MP3s for offline use.

Thanks for this site.
73, Clark


Posted: 2008-08-19 19:28
Safari 3.1.2 on OS X 10.5.4 works just fine.
Works on a blackberry using its browser with MP3 files too.


Posted: 2008-08-21 02:32
With IE7 on XP Pro SP3, it works fine!

mni tnx fer vy fb job!

73, Andy


Posted: 2008-08-21 18:33
I seem to have the same problem as la0dg - Brian but on IE and XP sp2. Everything except audio seems to work.
73
Rich
Administrator


Posted: 2008-08-21 18:41
Rich,

did you try to use the embedded MP3 option for the CW player? Is Flash installed? Does a Player show up at all, or is the space just blank, or shows an error message?

tnx, Fabian


Posted: 2008-08-22 03:52
Same problem as nu6t, getting errors on page as follows:

Line 1
Char 1 99 102 104 100 91
error js520 is undefined
code 0

I noticed that js520 is related to playing the lesson. Good luck with the fix! First time user,
Good job with this tutor. New things are buggy.

73

Barney


Posted: 2008-08-22 04:15
Found I can play/pause the lesson using the little triangle on the bar below the Play/Pause button. It's only the big button on top that is not working. Going back to practice.

73

Barney
Administrator


Posted: 2008-08-22 14:23
Yes, the little play button on the player itself should always work, but the big button atop it also changes the focus to the entry form, which makes things more comfortable.

It relies on JavaScript and I am not very experienced with that. Will try to find the error anyway and keep you updated.

73, Fabian
Administrator


Posted: 2008-08-23 16:32
I made some changes to the JavaScript code handling the player. I hope it works OK now with Firefox 2/3, and Internet Explorer 6/7.

73, Fabian


Posted: 2008-08-23 19:47
Hi Fabian:

The Play/Pause button is still not working. However, the "errors on page" warnings have disappeared. Great CW trainer! I am making some progress. My cousin K2UFT told me about this. I have been on and off trying to learn code for years. Maybe there is hope for me yet.

73

Tom (Barney)


Posted: 2008-08-26 07:02
Hi Fabian,
gleich Problem wie Barney, schade.
Bei Rufzeichen training die Geschwindigkeit, arbeitet umgekehrt,senkt statt wachsen,
73,
in3fhe


Posted: 2008-08-26 08:04
Dachte ich auch - aber: seit ich (mit Iceweasel 2.0.0.16) zu Beginn des Rufzeichenprogramms explizit mit der Maus aufs Eingabefeld klicke, gehts - allerdings erst ab dem 2. Rufzeichen.
Administrator


Posted: 2008-08-26 12:51
I did some changes, now the cursor should be focused on the entry field right after loading the Callsign Training page.

I hope this resolves the problem...


Posted: 2008-08-26 14:37
Fabian,

it works ok when using return key:
click on "call sign training link"
click on xxx wpm "start" button
hit Enter key to start training

it fails to work if in the last step the "Ok" button is clicked with mouse (loss of focus due to mouse click).

May be easiest just to remove this button - text says to hit enter anyway..

As said abov, I use Iceweasel.

Tnx agn for the good work

Gerd.

Administrator


Posted: 2008-08-26 16:16
OK, just fixed that: clicking the button will now bring the focus back to the field.


Posted: 2008-08-26 16:34
works perfectly now


Posted: 2008-08-26 21:25
Leidere bei mir geht es noch nicht, auch mit return key kein sound ..schade.
in3fhe


Posted: 2008-08-27 09:39
hello
je suis sur mac OS X pas de probleme tous fonctionne nickel



Posted: 2008-08-27 14:45
Safari 3.1.1 on Windows XP Pro also works fine.


Posted: 2008-08-29 22:06
Safari 3.1.1 on Mac OS 10.5.4 did not work but Firefox 3.0.1 works fine. Curious, since others have reported no problem with Safari. Safari shows the correct info on the practice page but none of the buttons work.
Administrator


Posted: 2008-09-02 22:04
Just trying Google's new Chrome browser myself, and all seems to work so far.


Posted: 2008-10-06 02:07
Hi

your excellent software will *not* play through USB earphones on my Macintosh computer

my configuration

Safari 3.1.2

Macintosh OS X V10.5.5
2 x 2 GHz Dual-Core Intel Xenon
4 GM RAM

USB earphones -- Plantronics

is this a bug?

do you have a work-around?

dave


Posted: 2008-10-06 14:06
finefirefox 2.0.0.6 on ubuntu 6.06

[Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6]

using older (2003) dell x3i PDA (no flash or javascript) results are as expected, minimal. Navigation to tests works ok, download of MP3 file works. Therefore practice still possible in off-line mode.

Brilliant site by the way, I started doing something very similar a while back using PHP and the usual linux command line utils on sys calls but never followed on beyond minimal proof of concept stuff. I have no excuses for not practicing now :)
Administrator


Posted: 2008-10-07 00:16
Hi Dave,

> your excellent software will *not* play through
> USB earphones on my Macintosh computer

I really don't know. Are those earphones a separate sound device or just somehow connected to another sound card? Does any other website where Flash is used to play sound (like youtube.com) work with them?

73, Fabian


Posted: 2008-10-12 09:59
Just to elaborate on the Chrome,

I've been using LCWO on Chrome now for over a month and I've had no issues at all, except occasionally I have to open the MP3 in a new Window because it doesn't play embedded. It doesn't happen all the time though.

It's the third site on my home page - thanks :)


Posted: 2008-10-20 15:54
On Mac OS X 10.4.11, Safari 3.1.2, old PPC iBook, no problems. I've mainly used the Koch method lessons, but I've had no problems with them.

I've also browsed this site with Nokia E51 and its built-in browser, with only one problem: the play-button does nothing :) That's not a problem though, as the MP3-link works. Only problems with mobile use are the menu on left edge (could it be optionally attached to the right edge -> less horizontal scrolling to see main area), and of course the input of the practice text.

But LCWO is a great site and keeps improving, thank you!
Administrator


Posted: 2008-10-20 18:06
I was thinking about making a "mobile friendly" version of LCWO (all via CSS preferably) so mobile users can use a minimalistic interface.

It's on the TODO list, but there are still a few items above it :)

73, Fabian


Posted: 2008-10-31 06:44
I am browsing with text only on opera. The white background causes the white top menu to disappear. I would use a mobile interface all the time because my connection is slow.


Posted: 2008-11-06 19:13
Running with firefox on fedora core 8 and it runs ok. only problem and maybe its harwdare config related, is that the first miliseconds of the audio have glitches, making it almost impossible to work with (if you wanna keep your precision rate :) eheh)


Posted: 2008-11-06 19:15
forgot to say that on windows system works just fine... (browser: IE7)
Administrator


Posted: 2008-11-06 20:12
Thanks for the report. Please check if the noise at the start is gone now. I added some silence to the start of each file because of trouble with Flash 10 (see other thread).

73, Fabian

Back to the Forum

You must be logged in to post a message.

$Id: forum.php 62 2015-01-12 17:34:44Z fabian $